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•
•
•

The NRCS plugin is an effective drag and drop tool for reliably adding Viz Mosart template 
instructions to an NRCS story.

Working with the NRCS Plugin
Setup and Administration
Integrating with an NRCS

Tip: This document contains animated graphics. If you are viewing as PDF, we recommend 
the web version.



http://docs.vizrt.com/viz-mosart-ncs-plugin/1.4/Mosart_NRCS_Plugin_Guide.html
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1 Working With The NRCS Plugin
The NRCS plugin delivers the functionality previously provided by the legacy Viz Mosart 
ActiveX plugin.

User Operations
Getting Help
Error Handling
API Documentation

1.1 User Operations
Searching for a Template
Modifying a Template
Adding Template Details to the NRCS
Template Change Alert
Optimizing Your NRCS Plugin Workspace
Copying the MOS Object Details
Modifying Existing MOS Objects

1.1.1 Searching for a Template
Locate a template by typing a variant or template type in the Search box. Auto-suggest starts 
displaying search results as you type.
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•

1.1.2 Modifying a Template

To modify production characteristics
Variables

Click on a template in the search listing. Properties (called Variables) that have been added 
to the template (using Viz Mosart's Template Editor) appear to the right.

You can temporarily override any defaults, and add new variables.
For example, in a Video Effects template, you may wish to change the source of the second 

Note: Variables are called Newsroom tags in the Viz Mosart Template Editor.
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•

input:

Transitions

The Transition field initially displays the default transition type. This value indicates the 
most significant template behavior.
You can temporarily modify this transition type, and then later restore the default transition 
(as originally set in the Template Editor).

1.1.3 Adding Template Details to the NRCS
Drag and drop the template into the required location of the story slug.

You can restore the default transition by clicking the Reset button.
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1.1.4 Template Change Alert
If simultaneous changes are being made to the active template set (by another operator 
using Viz Mosart's Template Editor), the Refresh button flashes orange. 
To fetch the latest changes, click the Refresh button.

1.1.5 Optimizing Your NRCS Plugin Workspace

Collapsing the Type listing
You can save some screen space taken by the Mosart NRCS Plugin by collapsing the Template 
Types panel: 

Click the Collapse button.

Note: The names of both the gallery and the template set of your selected template 
are always included with the MOS object that you store as a story item in your NRCS 
rundown. 
           Any future use of this NRCS MOS item will always point to exactly the same 
template (same gallery, template set and template name) when it displays in the Viz 
Mosart NRCS Plugin.
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1.

2.

Scaling the View
As the plugin is a web application you can set your preferred scale by zooming in and out.

For most browsers, you can use the shortcut Ctrl+mouse wheel.

1.1.6 Copying the MOS Object Details
You can work with the template's raw MOS data by first copying it to your PC's clipboard.

From a selected template, click Copy MOS.

1.1.7 Modifying Existing MOS Objects
Your rundown will usually contain slugs with MOS objects that have been created with either this 
Viz Mosart NRCS Plugin or the legacy component, Viz Mosart ActiveX.

To modify an existing MOS object
On the selected rundown story, double-click the slug or grommet that holds the story's MOS 
object.
The corresponding Viz Mosart template, complete with any control details like 
newsroomtags, crosspoints, transition, timings, is displayed in the Viz Mosart NRCS Plugin.
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3.
You make modifications direct in the plugin window.
The name of the template you are working and reference to which template set it is part of, 
is displayed on the border of the plugin menu.

When finished editing click Apply, then OK.

Note: You cannot modify a MOS object that refers to a not-found Viz Mosart 
template.
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Modifying MOS objects created with the Viz Mosart NRCS Plugin
MOS objects created by the Viz Mosart NRCS plugin include references to the gallery name 
and template set name.

If your rundown item refer to a template set that cannot be found in the gallery, the Viz 
Mosart NRCS plugin checks the active gallery  and template set for a corresponding 
template. This valid reference is then applied to the MOS object, when you click Apply on the 
replacement template.

Alternatively, you can manually search gallery/template sets to locate a similar template.
After editing and clicking Apply, the new (active) gallery and template set name are stored in 

Note: The active Gallery and/or Template set name may automatically change if your 
selected MOS object references a different gallery/template set. You are always 
notified if this happens.
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•

•

your rundown MOS object.

Editing MOS objects created by ActiveX
When working with MOS objects that were created with Viz Mosart's legacy NRCS plugin (Mosart 
Active-X) the currently selected gallery name and template set name will always be used as 
template source.

In the plugin, ensure to select correct gallery and template set before you start editing.

1.2 Getting Help
The NRCS Plugin documentation is continually updated and available online. This includes both 
this User Guide and the Release Notes.
You can also send your feedback directly to the Mosart NRCS Plugin design team.

Click the Question mark icon at the top right:

1.3 Error Handling
While navigating through templates, if there are exceptional conditions, the Viz Mosart NRCS 
Plugin displays an error message. 
See the example below:
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•

Please contact Vizrt Support if you encounter any error messages.

1.4 API Documentation
The NRCS Plugin also installs the Mosart REST API. Details about the API endpoints are provided in 
the open API documentation (Swagger Open API (OAS) documentation) at:
http://localhost:55142/docs

1.4.1 Examples
Retrieve all galleries:
http://localhost:55142/api/v1/galleries
(A list of gallery names is obtained)
Choose a gallery name from the list obtained in the previous example. For the sake of this 
example, assume that Local was on the list. (If not, choose some other gallery name.)
To retrieve the template sets for the gallery named Local:
http://localhost:55142/api/v1/galleries/Local/templatesets.

Note: Replace localhost with the IP address of the computer on which the API is installed.

http://localhost:55142/docs
http://localhost:55142/api/v1/galleries
http://localhost:55142/api/v1/galleries/Local/templatesets
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1.

2 Setup And Administration
This section describes setup and post-installation configurations, usually performed by a system 
administrator.

Setting up the NRCS Plugin
Download
Installation
Configuration
Enabling HTTPS
Verifying the Installation

Troubleshooting

Before the NRCS operators can work with Viz Mosart templates using the Plugin, the system 
administrator must complete a one-time setup.

2.1 Setting Up The NRCS Plugin
Perform all three procedures, Download, Installation and Configuration. These three procedures 
are all performed on your viz Mosart Server machine.

2.1.1 Download
Collect the latest software bundle from https://download.vizrt.com/
navigating to /products/VizMosart/Latest Version/WebComponents/.

2.1.2 Installation
Install the NRCS Plugin by running the Mosart Web Applications installer
MosartWebApplications.Bundle-n.n.n.n.exe.

https://download.vizrt.com/
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2.

3.

1.

2.

The web applications that will be installed are listed.
Click Install.
Any previous versions of the bundled Mosart Web Applications are automatically deleted 
from the local machine. 
After successful installation, the Mosart Web Applications Configuration Tool automatically 
displays.

2.1.3 Configuration
Open the Configuration Tool, a dashboard presents current installations and their status.

If the warning CONFIGURATION REQUIRED appears in the NRCS Plugin panel, click Configure.
Follow the guidelines below:

Note: After successful installation, a desktop shortcut provides access to a 
configuration assistant.
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Step Description

(1) Template location Select whether your Viz Mosart templates are defined 
in a local file or on a separate database.

(2) Template access Local: Usually C:\channeltemplates\

A check is made for existence at the stated 
destination, for all three files:

channeltemplates.xml
avconfig.xml
newsroomsettings.xml
If  all are found, a confirmation text Valid 
folder is displayed. 
Click Next.

Database: URL (Host + DB name) and DB access 
credentials
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•

a.

b.

c.

Step Description

(3) NRCS type Select the NRCS system you are using.
Supported systems are ENPS, iNEWS, Octopus.

Any NRCS that can handle html plugins should work 
(select Other), but the above 3 are supported.

mos id
Mandatory field if you select NRCS type ENPS, 
Octopus or Other.
(not used in iNews). 

To find yourMos ID

In the Manus Administrator console, type 
SETTINGS.
From the configuration panel that opens, 
look for MosId.
The value is defined in the column to the 
right (in this example mosart.mos)

For more details, see the Viz Mosart Administrator 
Guide, section Manus Administrator > Settings Editor 
MOS > NRCS Configuration.

http://docs.vizrt.com/viz-mosart.html
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3.

1.

2.
3.

1.

2.
•
•
•
•

Setup is complete and a confirmation menu summarizes your details.

2.1.4 Enabling HTTPS

Step 1 - Turn HTTPS on in Mosart Web Applications
Launch the Viz Mosart Web Applications Configuration Tool (a desktop shortcut is presented 
by default).
In the top right corner, switch on the HTTPS switch.
Provide certificate and key details (consult with your IT department to obtain this).

Note: This selection also turn on HTTPS for the Mosart Timing Display Guide.

Step 2 - Turn HTTPS on in Mosart Remote Dispatcher Service
Copy the file C:\Program Files (x86)\Mosart Medialab\Mosart 
Server\ConfigurationFiles\RemoteDispatcherServiceConfig.xml to C:\ChannelTemplates.
Fill in the following fields:

SignalRUseHttps: true
SignalRCertificatePath: <path_to_the_server.crt_created_above>
SignalRCertificateKeyPath: <path_to_the_server.key_created_above>
SignalRCertificatePassword: <the_passphrase_used_above>
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3.

1.

2.
a.

b.

3.

Restart the Remote Panel service

2.1.5 Verifying the Installation
After entering NRCS type, clicking Next starts a background Windows service, Mosart REST 
API (a combination of the REST API and the NRCS Plugin).
You can check that the NRCS Plugin is accessible by either:

In the Configuration Tool, clicking Open.

or
following the URL next to the Copy button.

To complete the integration, configure the NRCS side, according to the appropriate NRCS as 
described in section Integrating with an NRCS, where you will use the copied URL. 

2.2 Troubleshooting
At any time you can start the Viz Mosart Web Applications Configuration Tool and check operating 
status.

The plugin URL comprises the machine name, port number 55142, NRCS type 
and (when supported) mos id in the form: http://machine-name:55142/plugin
?nrcs={type}&mosid={mosid}
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•

•

A common error is when a Windows service has failed.

Try restarting the service with the Restart.

You can also rewrite any previously entered values with the Reconfigure button.
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1.

2.

3 Integrating With An NRCS
This section describes

NRCS Integration
ENPS
iNEWS
Octopus

The server-based plugin configuration described below avoids having to configure each 
individual NRCS client.
This section assumes the Viz Mosart NRCS Plugin has been successfully installed and set up, 
as described in section Setup and Administration.

3.1 NRCS Integration
The NRCS Plugin supports connections to

ENPS
iNEWS
Octopus.

You connect each client NRCS machine to the Viz Mosart server (which hosts the Mosart REST API.)

3.1.1 ENPS
In the Configuration Tool (if not already running, select Windows Start > Viz Mosart NRCS 
Plugin Configuration Tool) on the Mosart server, collect the NRCS Plugin's URL with the Copy
button:

On the ENPS machine, navigate to System Maintenance > MOS Configuration.

Note: Initial investigations show that the NRCS Plugin also works with OpenMedia. However 
this connection is currently not officially supported by Vizrt.
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3.

•
•

1.

2.

•

3.
•

•

•
i.
ii.

Paste the NRCS Plugin's copied URL, similar to the example below:

3.1.2 iNEWS
There are two possible setup routes, depending on whether your iNEWS version supports HTML5 
plugins. Please consult the documentation of your iNEWS system to determine whether this is the 
case.

iNEWS Clients with HTML5 Support
iNEWS Clients without HTML5 Support

iNEWS Clients with HTML5 Support
In the iNEWS client, from the directory navigation tree, open the file SYSTEM.MOS-MAP and 
verify that between TABLE-START DeviceTable  and TABLE-END  there is a line
mosart ...
If not, add the mosart reference,
For example: mosart MosartNRCSPlugin
For this step and the next, please refer to Avid's MediaCentral Newsroom Management Setup 
and Configuration Guide, section Configuring Newsroom Management for HTML5 (chapter 
HTML5 Plugins) .
If you have at least one HTML5 plugin already defined, you can skip this step. 
From Avid's Configuring Newsroom Management for HTML5, follow the 1 to 6 with one 
clarification:

Step 3: (name of the new queue): Use the name HTML-PLUGINS, as recommended by 
Avid.

Continue with steps 7 to 10, observing these clarifications:
Step 7: In case you skipped the previous step, the queue refers to SYSTEM.HTML-
PLUGINS
Step 9: (slug): Enter something like Viz Mosart NRCS plugin. (This is the string that will 
be shown in the Plugins sub-menu of the Tools menu.)
Step 10: (parameters): In the Story panel,

Enter 'URL = '.
At that exact spot, paste the URL copied from the Configuration tool
(if the Configuration Tool is not already running, select Windows Start > Viz 

•

Note: The URL comprises a combination of the plugin's URL + a fixed port number 
and Viz Mosart's MosId value in the form:
           http://machine-name:55142/plugin?nrcs=ENPS&mosid=xxxx.

If you need to derive current MosId value, see the item To find your Mos ID.



https://resources.avid.com/SupportFiles/attach/MediaCentral_Newsroom/MCNM-SCG-2021.11.pdf
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iii.

1.

2.

Mosart NRCS Plugin Configuration Tool)

.
Finally, append

mosItemBrowserProgID = Mosart.ActiveX
mosItemEditorProgID = Mosart.ActiveX

For example:

URL = http://BGO-EDR2:55142/plugin?nrcs=iNews

mosItemBrowserProgID = Mosart.ActiveX
mosItemEditorProgID = Mosart.ActiveX

iNEWS Clients without HTML5 Support
Installing the iNEWS Client Addon

For older versions of iNews without HTML5 support, you need to install a small wrapper utility, 
the Mosart NRCS Plugin - iNEWS Client Addon on each iNEWS client machine.

From the Vizrt FTP/products/VizMosart/Latest Version/WebComponents/
MosartNCSPlugin-1.3.0/
download and run the utility file MosartNRCSPlugin-iNEWSClientAddon-1.1.0.0.exe
Under Install options > Mosart NCS Plugin URL, paste the URL of the Plugin (http://machine-
name:55142/plugin?nrcs=iNews).

•

•

Note:
The parameter mosItemPlayerProgID mentioned in the Avid document is not
mandatory in this context.
The URL element mosid is not required for iNEWS.



Note: If Mosart ActiveX opens when trying to modify/edit a Mosart items (when double 
clicking on the item), you must first uninstall Mosart ActiveX.
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3.
4.

1.

Click Install.
Open/Restart your iNEWS Client.
The Viz Mosart NRCS Plugin is under:
Tools > Plugin > Mosart NRCS Plugin.

3.1.3 Octopus
In the Configuration Tool, (if not already running, select Windows Start > Viz Mosart NRCS 
Plugin Configuration Tool) on the Mosart server, collect the NRCS Plugin's URL with the Copy

Note: This is the URL you save with the Configuration Tool Copy button.
If the Configuration Tool is not already running, first select Windows Start > Viz 
Mosart NRCS Plugin Configuration Tool)

.



Note: If Mosart ActiveX opens when modifying a Mosart items (by double clicking on it), 
uninstall, then reinstall the file MosartNRCSPlugin-iNEWSClientAddon-1.1.0.0.exe.
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2.
3.

4.

5.

button:

Log-in to Octopus with Admin privileges.
From the sidebar, navigate to MOS Devices > Devices, select mosart and click Edit.

Select the Plugins tab:

Fill-in as below, and providing:
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a.
b.
c.

6.

A unique name
Version
The URL to the Viz Mosart NRCS Plugin (pasted from step (1).

Setup is complete. 
When editing a selected rundown, the user right-clicks for New > Create using <given name 
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of the plugin>

For more details, see the Viz Mosart Administrator Guide, section Manus Administrator > Settings 
Editor MOS > NRCS Configuration.

http://docs.vizrt.com/viz-mosart.html
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